Friday 20 May 2016

PPPoE Server With FTP (20MB Per User)

/interface bridge
add name=PPPoE
/interface ethernet
set [ find default-name=ether2 ] comment="Wan Network"
/ip pool
add name=pppoe-remote ranges=172.16.1.1-172.16.1.254
/ppp profile
add dns-server=10.10.0.1 local-address=10.10.0.1 name=my rate-limit=2M/2M \
    remote-address=pppoe-remote
/queue type
add kind=pcq name=Download-FTP pcq-classifier=dst-address \
    pcq-dst-address6-mask=64 pcq-rate=20M pcq-src-address6-mask=64
add kind=pcq name=Upload-FTP pcq-classifier=src-address pcq-dst-address6-mask=\
    64 pcq-rate=20M pcq-src-address6-mask=64
/queue simple
add comment="FTP 20M PER USER " name=FTP-Hit packet-marks=ftp_20M queue=\
    Upload-FTP/Download-FTP target=""
/interface bridge port
add bridge=PPPoE interface=ether1
add bridge=PPPoE interface=ether3
add bridge=PPPoE interface=ether4
add bridge=PPPoE interface=ether5
/interface bridge settings
set allow-fast-path=no use-ip-firewall=yes use-ip-firewall-for-pppoe=yes
/interface pppoe-server server
add authentication=pap,chap disabled=no interface=PPPoE max-mru=1480 max-mtu=\
    1480 mrru=1600 one-session-per-host=yes service-name=service1
/ip address
add address=192.168.93.6/24 interface=ether2 network=192.168.93.0
add address=10.10.0.1/24 interface=PPPoE network=10.10.0.0
/ip dns
set allow-remote-requests=yes cache-size=10000KiB servers=192.168.93.1,8.8.4.4
/ip firewall mangle
add action=mark-packet chain=prerouting comment="FTP 20M PER USER" dst-address=\
    10.10.0.0/24 new-packet-mark=ftp_20M passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat comment=PPPoE src-address=\
    172.16.1.1-172.16.1.254
add action=masquerade chain=srcnat comment=FTP src-address=10.10.0.2
/ip route
add distance=1 gateway=192.168.93.1
/ppp secret
add name=1 password=1234 profile=my service=pppoe

No comments:

Post a Comment